FTPShell
Home › Resources › Technical Guide

FTP technical references

The IETF (Internet Engineering Task Force) is a large open international community of network designers, operators, vendors, and researchers that has been charged with developing and maintaining internet related protocols and implementations. The IETF releases RFC documents which serve as the definitive guide for FTP, HTTP, and many other protocols. The following documents are useful for understanding and implementing the FTP protocol.


RFC 959
This document provides fundamental details for the implementation of a file transfer protocol that is compatible between various computer systems.

RFC 2228
This document extends the security features of the FTP protocol. These extensions provide authentication and integrity on both the control and data channels. New new optional commands and replies are also defined.

RFC 2640
This document extends the FTP protocol for international audiences, and defines support for multiple character sets.

RFC 2577
This document provides suggestions for system administrators and those implementing FTP servers about potential security issues such as "bounce attacks".

FTPShell Client

Windows FTP, SFTP and FTPS client with a transfer queue, folder sync, remote search, scheduled tasks and scripting. The Personal edition is free.

Find out more about FTPShell Client



Download the Free Trial

Download FTPShell Client and try every Enterprise feature free for 30 days; it then continues as the free Personal edition.

Go to the Download Page



Buy a License

Professional and Enterprise licenses for FTPShell Client, and Pro, Secure Pro and Secure Plus licenses for FTPShell Server.

Find out more about Licensing Options



FTPShell Server

A simple FTP, FTPS and SFTP server for Windows with SSH shell and Telnet access. Free Personal edition.

Find out more about FTPShell Server



Operating System Requirements

FTPShell Client runs on Windows Vista, 7, 8, 10 and 11 and Windows Server 2003 through 2025. FTPShell Server runs on Windows XP, 7, 8, 10 and 11 and Windows Server 2003 through 2025.